okkustom

OK what happened to your chump car today ?

4,813 posts in this topic

29 minutes ago, Bandit said:

Falken 615k is now the 615kplus or some such. Haven't heard yet how they wear and/or if it's now an autocross 200 wear versus endurance.

I heard the new k+ are like the starspec 2s

 

i hope it's true.  I only have 2 sets for the 24.  

Share this post


Link to post
Share on other sites
3 hours ago, Huggy said:

I heard the new k+ are like the starspec 2s

 

i hope it's true.  I only have 2 sets for the 24.  

 

You might want to read this from the Mosport just got home thread:

 

 We tried the Falken Azenis RT 615K +  but whatever they did to them compared to the old 615K's I didn't like. We used the same size, pressure and camber that has worked on our rims at Mosport before but they rolled really bad. Right into the Azenis writing on the sidewall. We added 5 psi and they seemed to be better but lap times went down and the front left was corded after only 6.5 hours.

Share this post


Link to post
Share on other sites
11 hours ago, RandomTask said:

Uggg, went to order our 3 sets of BFgoodrich tires and they're sold out EVERYWHERE. Kind of limited on size; (275/40/17)

 

Anyone have experience with the firehawk indy's? 

I have new Indys on my street Mustang in a 275/40-18 at the moment FWIW.  Very pleased with their feel and feedback so far.  No track time to speak of yet however.  There seem to compare very well in the performance per dollar (and even straight up) in any performance tests I've seen.

Share this post


Link to post
Share on other sites
5 hours ago, Ron_e said:

 

You might want to read this from the Mosport just got home thread:

 

 We tried the Falken Azenis RT 615K +  but whatever they did to them compared to the old 615K's I didn't like. We used the same size, pressure and camber that has worked on our rims at Mosport before but they rolled really bad. Right into the Azenis writing on the sidewall. We added 5 psi and they seemed to be better but lap times went down and the front left was corded after only 6.5 hours.

That sounds like the tire wanted more camber, not pressure.

Share this post


Link to post
Share on other sites

Posted (edited)

15 hours ago, RandomTask said:


BFG was recommended b/c of weight of vehicle (2880lbs) Will 3 sets of the Azenis last a VIR 24 stint? Would get the Falkens over the NT05's as they're equal on price. 

Toyo doesn't have anything in that size w/ a high enough tread wear rating. 

Toyo makes a 275 R1R with 200TW, but I wouldn't go that way if wear is your primary concern.

 

I never ran the old Falken, but we tried the new 615K+ during the same weekend as the new RS-4 earlier this year and didn't have a strong preference either way. It's not an "autocross compound", I've heard lots of comparisons to the ZII* and I would agree. I don't think you'll be disappointed with the Falken.

 

We ran a full 24 at High Plains Raceway last year on only 2 sets of 255's with a 3,000+lb car, but it's pretty easy on tires. 3 full sets sounds like enough to me. 

 

 

Edited by ABR-Glen
1 person likes this

Share this post


Link to post
Share on other sites

Ran on an AWD dyno yesterday to set a tune now that we have a programmable ecu. 189 at wheels which is pretty good I think. That's running 12 psi and we think we can run 14 pretty safe but don't have any idea on fuel consumption now. Tune is set to a little rich and going to keep it at 12psi.

 

I was dreaming last night of removing more weight from my pig but there really isn't much I can do.

 

Dyno shop found timing was 5 degrees more than its supposed to be set at. So I have to figure out how my teammate who sets the timing is off. 5 degrees would add knock I think and we were eating head gaskets. Fingers crossed that we don't blow the 4th motor. I am now expecting to grenade a transmission next.

 

Tonight is redoing the corner balance, alignment after we fix the ride height. Wed is a test day. Then it is only some little things to deal with. I might have time to work on other projects soon. 

1 person likes this

Share this post


Link to post
Share on other sites
3 hours ago, wvumtnbkr said:

That sounds like the tire wanted more camber, not pressure.

 

Monte that it was not my comment, it was another team that raced at Mosport.   We were not there and have not tried the new + tire.  

Share this post


Link to post
Share on other sites
33 minutes ago, Ron_e said:

 

Monte that it was not my comment, it was another team that raced at Mosport.   We were not there and have not tried the new + tire.  

I figured.  I was just commenting on the data available...

 

I will go check out that thread for more info.

Share this post


Link to post
Share on other sites
7 hours ago, ABR-Glen said:

Toyo makes a 275 R1R with 200TW, but I wouldn't go that way if wear is your primary concern.

 

I never ran the old Falken, but we tried the new 615K+ during the same weekend as the new RS-4 earlier this year and didn't have a strong preference either way. It's not an "autocross compound", I've heard lots of comparisons to the ZII* and I would agree. I don't think you'll be disappointed with the Falken.

 

We ran a full 24 at High Plains Raceway last year on only 2 sets of 255's with a 3,000+lb car, but it's pretty easy on tires. 3 full sets sounds like enough to me. 

 

 

Ended up pulling trigger on the falkens. Hopefully 3 sets last us the entire race :P

Share this post


Link to post
Share on other sites

kgSfQ7P.jpg

 

I made a purchase.  Now to get it working in the car..

4 people like this

Share this post


Link to post
Share on other sites
58 minutes ago, Huggy said:

kgSfQ7P.jpg

 

I made a purchase.  Now to get it working in the car..

 

Image result for you fancy

3 people like this

Share this post


Link to post
Share on other sites

And after spending a pile of money on a dyno tune at a shop that people said to not use. Kinda stuck as so very few AWD dynos around.  We went to the track and the car wouldn't run over 4000 rpm. Below 4000 it was like a diesel truck rolling coal from being so rich. Throttle position wasn't set. Speed density was on and I'm not running speed density. And I think it didn't run over 4000 as launch control was on and I don't have a speedo hooked up. Feel very ripped off. I have a expert helping me fix the tune via emails. Friday we might take it to the drag strip to fine tune the new tune. I don't know how it ran at the dyno shop. Unless the guy erased the tune at the end of the day when he tough he was saving it. Or he turned launch control on at the end, either to screw me over or because he didn't realize it would be a problem.

 

The very long list of things to do is only small things now as we got the bumper on, relocated the brake ducts because of the new intercooler and fixed the ducting to the rad/intercooler. Very long list....

 

Our notes said 1/8 toe out and when we checked we were 1/4 in. Don't know how that happened and now need to check if we have a part wearing, or someone hit something and didn't tell me.

 

2 weeks till race day.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now