Jump to content

Recommended Posts

Hey I have a 2003 CV Sport, low mileage (112) yesterday the Trans started shifting way to quick like the convert is locking up, If you hard brake it acts like it wants to stall. I have no "check" light on...any suggestions?

Share this post


Link to post
Share on other sites

  Even without the light, first course of action is checking fluid condition and running codes.

 Sorry no clue otherwise 

Share this post


Link to post
Share on other sites
2 hours ago, Team Infiniti said:

  Even without the light, first course of action is checking fluid condition and running codes.

 Sorry no clue otherwise 

no codes, no engine light. I think it might be a throttle position sensor.

Share this post


Link to post
Share on other sites
1 hour ago, TiredBirds said:

no codes..........think it might be a throttle position sensor.

What does the interwebs say?        TPS will generally (and easily) throw a code.

Share this post


Link to post
Share on other sites
2 hours ago, Team Infiniti said:

What does the interwebs say?        TPS will generally (and easily) throw a code.

One mentioned a converter solenoid. My buddy (ASE guy) said the TPS is a common fault on cars in the low-rpm range and would cause these symptoms. It only does it under "grandma" driving WOT or shifting manually will not cause the issue. 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×